In this project, you will learn the web publishing skills you need to

- Plan a website
- Define a website
- Create a basic town website
- Work with text and text formats
- Work with images and image rollovers
- Work with hyperlinks
- Check your site against accessibility standards
- Test your website for errors
- Manage your website

Activity 1: Planning the Website

Approximate time to complete: 30 minutes or more, depending on the scope of the project

In this activity you decide the structure of your website. You draw a flowchart that shows all the pages in your website and how they link together. You then plan how you will lay out the content of each page in your website.

In this project the term site refers either to the website or to the local storage location (on your computer) for the files belonging to the website.

PLANNING THE SITE LAYOUT

Planning and organizing your site carefully from the start can save you time later. The first step is to sketch a flowchart that shows the number of pages in the site and how the pages are linked. A flowchart is a sort of map of the site.

The figure on the next page shows a simple flowchart of the sample Half Moon Bay website.
There are no standard symbols for drawing the structure of a website. Here are some suggestions:

- Use rectangles to indicate pages.
- Use lines to indicate the link structure between pages.
- Include lines to indicate links that lead outside the website. (Generally, you will need to add these links to the flowchart after you have designed the individual pages for your site.)

**To create the site flowchart:**

1. Draw a rectangle for each page of your site on one sheet of paper. (Grid paper is convenient, if it is available.)
2. Write the page title in each rectangle.
3. Draw connecting lines to show the links between pages. (If you are adding more pages than the ones shown in the sample flowchart, be sure to add lines indicating the links.)
4. Draw lines to show links from pages to external sites or e-mail addresses (when you have this information).

After creating the site flowchart, plan the design of the site pages by creating a storyboard for each page.

**PLANNING THE HOME PAGE**

The home page is the entrance to your website. It introduces the site, with information and navigation links to the other pages in the site. Most home pages include a title, an image or logo, informational text, and navigation links (which serve as a table of contents for the site).

Planning the home page is a very important step. You don’t need to map out every detail, but you should think about the content links you want to provide for navigation, the information and images you want on the page, and the overall look and feel of the website.
In a film, television show, or television commercial, designers use the term *storyboard* to refer to a panel or series of panels on which sketches depict important scene changes and actions. Here, *storyboard* refers to the sketch of a web page. On a storyboard you block out areas of the page to show the placement of such elements as the title, images, text, and navigation links.

**To create a storyboard for the home page:**

1. On a sheet of paper, draw boxes as placeholders for the elements of your home page. For example, the sample Half Moon Bay home page has the following layout:
   - **Title of the website:** Draw a rectangular box near the top of the page.
   - **Image:** Draw a 2-inch square at the left margin.
   - **Informational text:** Draw a 2-inch by 4-inch rectangle beside the image.
   - **External links:** Draw and a 2-inch by 6-inch rectangle underneath the image.
   - **Navigation links:** Center a rectangular box near the bottom of the page.

   These are the main elements of the home page used in this project. If you are adding other elements, be sure to include them on your storyboard.

2. Label each box.

The home page of a town website might contain navigation links to topics such as these:

- Schools
- Event calendar
- News
- Local government directory
• Civic clubs and organizations
• Churches
• Town history
• Map
• Leisure activities

The page might also include a photograph of the town or another image appropriate to the town and a way to contact the local government or a civic organization by using e-mail.

**PLANNING THE OTHER PAGES**

Think about how you want to organize the content you have for the other pages. Are there paragraphs of text? lists? tables of information?

The other pages of the sample Half Moon Bay site, for example, include the following types of content:

• Paragraphs of text, a bullet list, and three images on the History page
• A table of information on the Directory page
• A bullet list under each heading on the Events page
• An image and paragraphs of text on the Map page

Decide the best way to organize your content. On separate pieces of paper, create storyboards for the other pages of your site. Remember that viewers can more easily understand and navigate your site if you place the page title and navigation links consistently.

---

**Activity 2: Getting Acquainted with Dreamweaver MX**

*Approximate time to complete: 20–30 minutes*

This activity briefly introduces the key parts of Macromedia Dreamweaver MX. If you are already familiar with Dreamweaver MX, you can skip ahead to Activity 3: Setting Up the Local Site and Root Folders.

Macromedia Dreamweaver MX is a professional Hypertext Markup Language (HTML) editor for visually designing and managing websites and pages. The great thing about Dreamweaver is that you don’t have to write any HTML code to design great web pages. You just choose what you want to do, such as insert a graphic or change formatting, and Dreamweaver creates the HTML needed. (If you are interested in looking at the HTML created on each Dreamweaver page, choose **View > Code** from the menu bar.) Dreamweaver MX makes it easy to get started and provides you with helpful tools to enhance your web design experience.
In Windows, when you first install Dreamweaver MX, you will choose between two very different workspace layouts: an all-in-one-window integrated layout (Dreamweaver MX workspace, or Homesite/Coder-Style workspace), and a floating layout (Dreamweaver 4 workspace). On the Macintosh, only the floating layout is available. This project assumes you are using the Dreamweaver MX workspace. The Dreamweaver MX workspace consists of the main Document window and three smaller areas: the Insert bar, the Property inspector, and panels.

The Dreamweaver MX workspace accommodates different work styles and levels of expertise. Here are some of the most commonly used components:

- **The Document window** displays the current document as you create and edit it. This is where you make the pages for your site.
- **The Insert bar** contains buttons for creating and inserting objects such as images, tables, layers, and frames you might want to add to your web page.
- **The Property inspector** displays properties for the selected object or text and lets you modify those properties.
- **On the right side of the Dreamweaver MX workspace are panels** you can expand or collapse as you need them.
USING THE DOCUMENT WINDOW

You do most of your design work in the Dreamweaver MX Document window. You can add and manipulate text, images, menus, tables, and numerous other elements in the Document window, and it will display an approximate representation of your web page.

To type in the Document window:

1. Start Dreamweaver MX.

   The Document window creates a new, blank page.

2. Click in the Document window and type a few words.

3. To start a new paragraph, press Enter (Windows) or Return (Macintosh). To start a new line (without the normal space provided between paragraphs), press Shift+Enter (Windows) or Shift+Return (Macintosh).

   The insertion point (a short vertical segment) indicates where your text will appear, just as in a word processor. Click anywhere in text you have typed to re-position the insertion point.

The document status bar, found at the bottom of the Document window, provides information about the document you are creating, including the size of the Document window, the document file size and estimated download time. The left side of the status bar is the HTML tag selector; you can click a tag to select an element in the window.

The Document toolbar, found at the top of the Document window, contains an area for you to enter the title of your document. The title you enter will display in the Document title bar. The toolbar also contains buttons that let you toggle between the Design view and the Code view of your document.

- Design view shows what the page will look like in a web browser.
- Code view shows the HTML code for the page.

For this project, use the Design view. Other buttons give quick access to file management and navigation features.

USING THE INSERT BAR

The Dreamweaver MX Insert bar contains several categories of buttons for creating and inserting objects such as tables, layers, and images. (You can also insert each object by choosing the object from the Insert menu.) Let’s look at the Insert bar categories you’ll use in this project.
To view the Insert bar:

1. Click the Common tab on the Insert bar.

   The Insert bar defaults to the Common category when you start Dreamweaver. The Common category contains buttons for creating and inserting the most commonly used objects, such as images, tables, and layers. You will use the Common category most often in this project.

2. To display the Characters category, click the Characters tab along the top of the Insert bar.

   The Characters category contains special characters such as the copyright symbol, the symbol for pounds sterling, curved quotation marks, and the trademark symbol.

3. To insert an object from the Insert bar, drag the object’s icon from the Insert bar to its place in the Document window and drop it. Try it now by inserting a character from the Characters category.

   Note: Another method is to place the insertion point in your document where the object should appear and then click the object’s icon on the Insert bar.

4. To display the Layout category, click the Layout tab along the top of the Insert bar.

   The Layout tab lets you choose between two ways to view and manipulate tables and layers. In Standard View, you can insert a table as a grid of rows and columns and then manipulate the grid. You can also draw and manipulate multiple layers. In Layout View, you can draw, resize, and move cells on the page. In this project, you use only the Standard view.

Following is a brief description of the Insert bar categories that will not be used in this project. To learn more about them, use the Dreamweaver Help feature.

- The Application category contains buttons for adding server behaviors to a web page.
- The Forms category contains buttons for creating forms and inserting form elements such as radio buttons, check boxes, and menus.
- The Frames category contains buttons for creating different layouts within a frameset.
- The Head category contains buttons for adding various head elements, such as meta, keywords, and base tags.
- The Media category contains buttons for inserting special items such as applets and plug-ins.
• The **Script** category contains buttons for inserting script (JavaScript, VBScript) elements into a web page.

• The **Tables** category contains buttons for inserting a table and for inserting table-related tags (table, tr, th, td, or caption) in the code.

• The **Templates** category contains buttons for saving a document as a template file.

• The **Text** category contains buttons for inserting text- and paragraph-formatting tags in the code.

**USING THE PROPERTY INSPECTOR**

The **Property inspector** (the panel below the Document window, labeled **Properties**) lets you examine and edit properties of the currently selected object or text in the Document window.

The Property inspector is context sensitive—it changes based on what you have selected in the Document window. For example, when you work on text, the Property inspector shows the attributes of that text, such as size, color, and font. When you work on a table, the Property inspector shows table attributes.

The insertion point was in the page title in the following figure, so the Property inspector shows the text attributes and formatting.
The insertion point was on the image in the following figure, so the Property inspector displays the image attributes and formatting.

To expand or collapse the Property inspector:

1. If the Property inspector is not already displayed, choose Window > Properties from the menu bar.

2. Click the expander arrow in the lower right corner of the Property inspector.

This expands (or collapses) the Property inspector to show (or hide) additional properties.
**USING THE PANELS**

The Dreamweaver MX workspace displays panels you can expand or collapse as you need them. You can reconfigure the number and type of panels visible. (By default, the panels appear on the right side of the screen.)

To show or hide all panels, including the Property inspector, choose View > Hide Panels or View > Show Panels from the menu bar.

You will not use these panels in this project. To learn more about them, use the Dreamweaver Help feature.

Close the Document window without saving it.

---

### Activity 3: Setting up the Local Site and Root Folder

*Approximate time to complete: 15–20 minutes*

A website consists of folders containing files such as documents, images, and other media. When you create a website, you first need to establish the location of the website and all its related folders and files.

In this activity, you create the folder structure on your computer to store all the files for your website. You then use Dreamweaver MX to define your local site and identify the root folder that will contain all the files for your site. (Note that before you can place your site on a web server, you first need to create it locally on your computer.)

#### PLANNING THE LOCAL SITE FOLDER

By creating and editing your pages on a local site on your computer before you copy the files to a web server, you can test your website to make sure it works properly before you make it available for public viewing.

Every site is contained in a main folder, called the root folder. Most designers create subfolders inside the root folder to organize the site contents. The sample project site is organized with the site pages at the top level of the root folder. The root folder contains two subfolders—one for images and one for text files.

**To create the site folder structure:**

To set up a site similar to the sample Half Moon Bay site illustrated in this project, create a root folder that will contain the web pages. Then create subfolders for images and text files.

1. Create a root folder on the hard drive. Name it **half-moon-bay_site** (or the name of your town).

   **Note:** Do not place your root folder within the Dreamweaver MX application folder. If you ever need to reinstall Dreamweaver, you would lose your work.

2. Create two subfolders in the root folder: one named **images** and the other named **content**.
Your folder structure should be similar to the figure below.

If you are creating the sample Half Moon Bay website, copy the image files provided by your teacher into your images subfolder. Copy the text files into your content subfolder.

When you create a larger website (ten or more pages), it is helpful to group each set of related pages in a separate subfolder inside the root folder. For example, if your site had several pages related to the history of your town, you could put them all in a subfolder named history.

**To define the website:**

The purpose of defining your website is to communicate to Dreamweaver the name and location of the root folder.

1. Start Macromedia Dreamweaver MX.
2. From the menu bar at the top of the screen, choose Site > New Site.
   The Site Definition dialog box opens. If necessary, click the Advanced tab.
Note: If you click the Basic tab, Dreamweaver will lead you step by step through the complete process of defining a website, including the use of server technology.

3. From the Category list, select Local Info (if it’s not already selected).

4. In the Site Name text box, type *Half Moon Bay* or your own town, school, or class name.

5. Beside the Local Root Folder box, click the Folder icon. Navigate to the location on the hard drive where you stored your root folder.

6. Make sure you’re viewing the contents of the half-moon-bay_site folder in the Choose Local Root Folder for Site Half Moon Bay dialog box. Then click Select (Windows) or Choose (Macintosh).
7. You return to the Site Definition dialog box. Make sure **Refresh Local File List Automatically** and **Enable Cache** are checked.

If you know the URL your completed website will use, enter the information in the HTTP Address text box. Otherwise, you can add this information later, when you are ready to publish the site on a remote server.

8. Click **OK** to define your local site and folders. The “initial cache” message alerts you that the initial site cache is being created. Click **OK**.
Activity 4: Creating the Home Page

Approximate time to complete: 45–60 minutes

In this activity, you build the home page for your website.

BUILDING THE HOME PAGE

There are many considerations when designing web pages. In this project, you focus on just the basic design elements needed to build this website. One basic element is the background color of the pages. Adding color to the background can add interest and help maintain the uniformity and identity of a site. Use caution, however, when selecting a background color because the wrong combination of background and text color can make your text difficult to read.

To create a new document for the home page:

1. Start Macromedia Dreamweaver MX.

2. Choose File > New from the menu bar.

3. In the New Document dialog box, select Basic Page and click Create.

A new untitled Document window opens.

To save the home page:

1. Choose File > Save from the menu bar.

   The Save As dialog box opens. It displays the folders in the site root folder. You will save the file in the root folder.
2. Type *index.htm* (Windows) or *index.html* (Macintosh) in the **Filename** box.

   When you use the filename “index,” Dreamweaver automatically specifies that page as the home page. Then you don’t have to go through a separate step to specify the home page.

3. Click **Save**. The filename now appears on the title bar of the Document window.

**To set a page title for your document:**

1. In the **Title** text box (located in the Document tool bar), type *Half Moon Bay Home Page* (or the name of your town).

2. Press **Enter** (Windows) or **Return** (Macintosh).

   When this page is opened in a web browser, this title will appear on the title bar of the browser window. It is also the title used when the page is added to a browser’s Favorites (Microsoft Internet Explorer) or Bookmarks (Netscape Explorer) list.

**To change the background color:**

1. From the menu bar, choose **Modify > Page Properties** to open the Page Properties dialog box.

2. Experiment with the background color. Click the **Background Color button** (next to the Background label) to open the color picker. The pointer changes to an eyedropper.

3. As you select a color, click **Apply** to preview how your selection will appear on the page.

   The sample project uses the default background color (white), but feel free to choose another color.

4. When you are satisfied with the background color, click **OK** to close the Page Properties dialog box.

   **Note:** There are several ways to delete an element or action in Dreamweaver MX. You can use the Backspace and Delete keys. Alternatively, you can use the Edit commands: Cut, Clear, and Undo. The Undo command can undo the last 50 steps.
To insert text and hyperlinks:

1. Position the insertion point at the top of the Document window. (Click in the Document window.)

2. Type *Half Moon Bay* (or the name of your town). Press **Enter** (Windows) or **Return** (Macintosh) to add a paragraph break.

3. Select the text and change its formatting attributes by using the Property inspector. Experiment by clicking the format, size, color button, font style, and alignment boxes.

   **Note:** If the Property inspector isn’t open, choose Window > Properties from the menu bar.

   The sample Half Moon Bay home page title has the following settings:
   - Format: Heading 1
   - Size: None
   - Color: Dark red
   - Font style: Verdana, Arial, Helvetica
   - Alignment: Left-aligned

4. Position the insertion point below the heading “Half Moon Bay.” Add another paragraph break by pressing **Enter** (Windows) or **Return** (Macintosh). Then type a sentence directing users to a useful website, such as *Go to the City of Half Moon Bay website.*
5. Select the words “City of Half Moon Bay” (or the reference to a website related to your town).

6. On the Property inspector, in the Link text box, type your link, such as http://www.half-moon-bay.ca.us, and press Enter (Windows) or Return (Macintosh).

   The hyperlink appears as underlined text on your web page.

   Any time you select text and add a URL in the Link text box, a hyperlink is created. Hyperlinks appear as underlined text on your web page.

7. Add another paragraph break and type another website reference, such as Go to the Cabrillo Unified School District website.

8. Select “Cabrillo Unified School District” and type http://www.cabrillo.k12.ca.us in the Link text box.

9. If you want to make text smaller, select the text and change the size to a number such as −1.

To insert images:

1. Position the insertion point below the page heading “Half Moon Bay.”

2. On the Common tab of the Insert bar, click Image (the tree button).
The Select Image Source dialog box opens. The dialog box displays any folders and files stored in the site root folder.

3. Select the **images** folder, then click **OK** (Windows) or **Open** (Macintosh) to open it. Select your home page image, such as **hmb-coast.jpg**, and click **OK** (Windows) or **Open** (Macintosh).

The image is inserted at the position of the insertion point.

4. If necessary, click the image to select it and display the image Property inspector. You can resize the image by dragging any of the handles on the edge of the image.

5. Position the insertion point to the right of the image and add a line break by pressing **Shift+Enter** (Windows) or **Shift+Return** (Macintosh).

**Note:** A line break puts the insertion point at the left margin, just as a paragraph break does. However, a line break does not create a new paragraph, so there is less space above the new line of text.
6. Under the image, type a caption such as *The Pacific coastline looking north from Half Moon Bay.*

**To provide accessibility:**

A website is **accessible** if it is usable for people with visual, auditory, or other disabilities. People with disabilities (as well as many visually-impaired elderly web users) use a range of techniques to access the web. You can add descriptive alternate text to each image, so that web users with a browser that reads the site aloud can “see” the images. In most browsers, alternate text also pops up when the user moves the pointer over the image.

1. Click the coastline image to select it.

2. On the Property inspector, locate the Alt text box.

3. In the Alt text box, type a description of the image, such as *Photograph of the Pacific coastline off Half Moon Bay.*

Good web designers add alternate text tags to every image on site pages.

**To insert an e-mail link:**

You can insert an e-mail link to an important office such as your town or neighborhood council.

1. Position the insertion point at the end of “Go to the Cabrillo Unified School District website” and add a paragraph break by pressing **Enter** (Windows) or **Return** (Macintosh).

   The insertion point should be on the line below “Go to the Cabrillo Unified School District website.”

2. On the **Common** tab of the Insert bar, click **Email Link** (the envelope button). In the Text box, type a direction, such as *Send email to the Half Moon Bay City Council.* In the Email text box, type the address, such as **someone@halfmoonbaycouncil.ca.us.**

3. Click **OK.**
Your page should look something like the one below.

To place text in a specific area (insert a layer):

You may want to place text in a very specific area of the page. One of the ways you can do this is to insert a layer. A layer is a container for HTML content (such as text and images) that you can position anywhere on a page. Layers can contain text, images, forms, plug-in objects, and even other layers. Any element you can place in the body of an HTML document you can also place on a layer.

1. Click the **Layout** tab on the Insert bar.
2. In the Layout category, click the **Standard View** button (if necessary).
3. To switch to the Common category, click the **Common** tab.
4. Click **Draw Layer** (fifth button from the left) and position the pointer in the Document window.

The pointer changes to crosshairs, indicating that drag-and-draw is in effect.
5. Position the crosshairs near the top right corner of the image and drag to draw a box beside the image, 3 or 4 inches wide by about 3 inches tall.

**Note:** The layer outline may look like it has moved up above the image. Don’t worry. It will be aligned with the top of the image when viewed in a web browser.

6. Click inside the layer to position the insertion point on the layer. Enter the following information about Half Moon Bay (or similar information about your town). Press **Enter** (Windows) or **Return** (Macintosh) at the end of each item.

   State: California  
   County: San Mateo  
   Population: 16,215  
   Mayor: Dennis Coleman  
   Schools: Half Moon Bay High School  
   Pilarcitos/Alternative High School  
   Cunha Intermediate School  
   Hatch Elementary School  
   Chief Industries: Agriculture (primarily flowers), tourism, and commercial fishing

7. Using the Property inspector, change the text style, size, color, and alignment as you prefer. Your page should look like the figure below.
**Note:** If you press Enter (Windows) or Return (Macintosh), you create a paragraph break. When you want less space to appear between lines of text but want text to appear on separate lines, use a line break. To insert a line break, hold down the Shift key as you press Enter (Windows) or Return (Macintosh).

**To preview the home page:**

1. Choose **File > Save** from the menu bar.

2. From the menu bar, choose **File > Preview in Browser** and then choose the browser you want to use to preview your newly created web page.

3. Test the link and the e-mail sender. (Don’t actually send an e-mail message. Just make sure the e-mail sender opens when you click the e-mail link.)

4. Close the browser window.

5. Close the home page.
Activity 5: Creating the Other Web Pages

Approximate time to complete: 45–60 minutes

In this activity, you create the History, Directory, Events, and Map pages for your website.

BUILDING THE HISTORY WEB PAGE

It is very easy to include previously created text on web pages. You do not need to retype information from documents you already have. All you need to use are the Copy and Paste commands.

First, create a new Document window in which you will build the History page.

1. In Dreamweaver MX, choose File > New from the menu bar.

2. In the New Document dialog box, select Basic Page and click Create.

   A new untitled Document window opens.

To save the History page:

You should save your work on a page as you build it, but always save a page when you are ready to work on another page.

1. Add a title to this page. On the Document toolbar, select Untitled Document in the Title text box and type a title such as Half Moon Bay History.

2. Make any other changes to the page properties according to your design plan.

3. From the menu bar, choose File > Save.

4. Navigate to the root folder.

5. Type history.htm (Windows) or history.html (Macintosh) in the Filename text box.

6. Click Save.

To incorporate previously created text:

You use both Dreamweaver MX and a word processor in these steps.

1. In a word processor, locate and open the prepared text file called history.doc (or your own history text file).

   The text file history.doc is in the content subfolder of the root folder.

2. Use the Copy command of the word processor to copy the text.

3. Return to the History page in Dreamweaver MX. Use the Paste command to place the text on the page.
4. Use the Property inspector to change the text attributes of the page title, so it matches the format of the title on the home page.

5. Change text attributes of the paragraphs so the page is well-organized and readable.

Note: The text-editing commands in Dreamweaver MX are similar to those in word processors. You can access these commands from the Edit menu or by using the keyboard commands listed here.

<table>
<thead>
<tr>
<th>Command</th>
<th>Windows</th>
<th>Macintosh</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copy</td>
<td>Ctrl+C</td>
<td>Command+C</td>
</tr>
<tr>
<td>Cut</td>
<td>Ctrl+X</td>
<td>Command+X</td>
</tr>
<tr>
<td>Paste</td>
<td>Ctrl+V</td>
<td>Command+V</td>
</tr>
<tr>
<td>Clear</td>
<td>Delete/Backspace</td>
<td>Delete/Backspace</td>
</tr>
</tbody>
</table>

To create an unordered bulleted list:

Lists are usually easier to read and understand if they are set off from the surrounding text. In Dreamweaver MX you can create three types of lists:

- An unordered list (with square, round, or no bullets)
- An ordered list (with numbers, letters, or roman numerals)
- A definition list (in which the first line is a term or phrase and the second line is indented)

1. Position the insertion point at the end of the last text line and press Enter (Windows) or Return (Macintosh) to insert a paragraph break.

2. Select the paragraphs of the list to which you want to add bullets—in the Half Moon Bay History sample, the historic sites listed at the bottom of the page.

There are several historic sites you can see today in Half Moon Bay:

- James Johnston House
- Half Moon Bay Jail
- Half Moon Bay City Hall
- Thomas Johnston Barn
- Ocean Shore Railway Station
3. On the Property inspector, click **Unordered List** (bullets button) or choose **Text > List > Unordered List** from the menu bar.

   The paragraphs in the list are indented and set off with bullets.

   ![Unordered List](image)

   **To add hyperlinks:**

   A simple way to link your web page to information on other websites is to change one word or a phrase into a **hyperlink**. A **hyperlink** is text or a graphic that links to a different web page or to another section of the same page.

   1. Select words such as “James Johnston House” in the list of historic sites.
   2. On the Property inspector, type the link, such as `http://www.johnstonhousehmb.org`, in the Link text box.

   **Note:** When you enter URLs in the Link text box, you must include “http://” for the link to work.

   The hyperlinked text appears underlined on the page.

   ![Hyperlinks](image)

   **To insert images in a table:**

   You can use tables to lay out columns and rows of data, text, and graphics. Once you create a table, you can easily modify its structure and how it looks. On this web page, you use a table to display photographs of three historic buildings, with a caption under each photograph.

   1. Position the insertion point at the end of “Ocean Shore Railway Station” and press **Enter** (Windows) or **Return** (Macintosh) to add a paragraph break.
2. To remove the bullet point from the new paragraph, choose Text > List > None from the menu bar.

3. In the Common category on the Insert bar, click Insert Table.

   The Insert Table dialog box opens.

4. Set Rows to 2, Columns to 3, Width to 97%, and Border to 0 (for no border).

   The default settings for the rest of the table attributes are fine.

5. Click in the first cell (in the first row) of the table. In the Common category on the Insert bar, click Image.

   The Select Image Source dialog box opens.

6. Select the images folder, then click OK (Windows) or Open (Macintosh) to open it. Select the johnston_house.jpg file and click OK (Windows) or Open (Macintosh).

   The image is inserted in the first cell.

7. Insert the file jail.jpg in the second cell in the first row. Insert the file city_hall.jpg in the third cell in the first row.

8. Click in the first cell in the second row of the table. Type a caption for the first photograph, such as James Johnston House. Select the text and use the Property inspector to format it as you please.

9. Add a caption for the second photograph, such as Jail, in the second cell in the second row. Add a caption for the third photograph, such as City Hall, in the third cell in the second row.
10. If you would like to add a border to each image, select an image and type a number in the **Border** text box on the Property inspector.

---

To preview the History page:

1. Save the History page.

2. To preview your work in a browser, click **Preview/Debug in Browser** (globe button) on the Document toolbar. Select the browser you want to use to preview the web page.

3. Close the browser window and then close the History Document window.

**BUILDING THE DIRECTORY PAGE**

You can use tables to lay out columns and rows of data, text, and graphics. Once you create a table, you can easily modify its structure and how it looks. On this web page, you use a table to communicate contact information for local organizations.

First, create a new Document window in which you will build the Directory page.

1. In Dreamweaver MX, choose **File > New** from the menu bar.
2. In the New Document dialog box, select **Basic Page** and click **Create**.

A new untitled Document window opens.

**To save the Directory page:**

You should save your work on a page as you build it, but always save a page when you are ready to create another page.

1. Add a title to this page. On the Document toolbar, type a title such as *Half Moon Bay Directory* in the **Title** text box.

2. Make any other changes to the page properties according to your design plan.

3. From the menu bar, choose **File > Save**.

4. Navigate to the root folder.

5. Type *directory.htm* (Windows) or *directory.html* (Macintosh) in the **Filename** text box.

6. Click **Save**.

**To add a table:**

1. Type a heading for the new page, such as *Half Moon Bay Directory* (or the name of your town). Press **Enter** (Windows) or **Return** (Macintosh) twice to add a couple of paragraph breaks before you format the heading.

2. Select the heading on the first line and format it by using the Property inspector.

3. Position the insertion point below the page heading. In the **Common** category on the Insert bar, click **Insert Table**.

   The Insert Table dialog box opens.

4. Set **Rows** to 19, **Columns** to 3, **Width** to 500 Pixels, and **Border** to 1.

   The default settings for the rest of the table attributes are fine.

5. Click **OK**.
A 19-row by 3-column table is added to the page. The table is surrounded by handles, indicating that the table is selected. (If it is not selected, click within the table and choose Modify > Table > Select Table from the menu bar)

5. On the Property inspector, click the arrow beside the Align box and select Center.

The table is centered horizontally on the page.

6. Click in the first cell of the table.

The Property inspector changes to reflect the attributes of the cell.

7. To see more of the cell properties, expand the Property inspector if necessary by clicking the expander arrow in the lower right corner of the inspector.

Tables in Dreamweaver MX use commands similar to those in word processors. You can add and delete rows; split and merge cells; and modify cell, row, and column properties.
8. Type the following sample data in the table, or type information from your own town. To move from one cell to the next, press the Tab key or click in a cell.

<table>
<thead>
<tr>
<th>Organization</th>
<th>Address</th>
<th>Telephone</th>
</tr>
</thead>
<tbody>
<tr>
<td>City Council</td>
<td>501 Main St</td>
<td>555-8270</td>
</tr>
<tr>
<td>Police Department</td>
<td>537 Kelly Ave</td>
<td>911 (Emergency)</td>
</tr>
<tr>
<td>Library</td>
<td>620 Correas St</td>
<td>555-2316</td>
</tr>
<tr>
<td>Environmental Service Agency (Project Read)</td>
<td>620 Correas St</td>
<td>555-9406</td>
</tr>
<tr>
<td>Coastsdie Opportunity Center</td>
<td>99 Avenue Alhambra, El Granada</td>
<td>555-9071</td>
</tr>
<tr>
<td>Parks &amp; Recreation Dept (Community Center)</td>
<td>535 Kelly Ave</td>
<td>555-8297</td>
</tr>
<tr>
<td>Public Health Clinic (Community Center)</td>
<td>535 Kelly Ave</td>
<td>555-2553</td>
</tr>
<tr>
<td>Public Health Nursing</td>
<td>625 Miramontes</td>
<td>555-5236</td>
</tr>
<tr>
<td>Half Moon Bay High School</td>
<td>Lewis Foster Dr</td>
<td>555-7200</td>
</tr>
<tr>
<td>Pilarcitos/Alternative High School</td>
<td>498 Kelly Ave</td>
<td>555-7224</td>
</tr>
<tr>
<td>Cunha Intermediate School</td>
<td>Kelly St &amp; Church St</td>
<td>555-7290</td>
</tr>
<tr>
<td>Hatch Elementary School</td>
<td>490 Miramontes</td>
<td>555-7160</td>
</tr>
<tr>
<td>Elkus 4-H Youth Ranch</td>
<td>625 Miramontes, Suite 200</td>
<td></td>
</tr>
<tr>
<td>Half Moon Bay Review</td>
<td>714 Kelly Ave</td>
<td>555-4424</td>
</tr>
<tr>
<td>Coastsdie Young Actors Workshop</td>
<td></td>
<td>555-6143</td>
</tr>
<tr>
<td>Coastal Repertory Theatre</td>
<td>1167 Main St</td>
<td>555-0998</td>
</tr>
<tr>
<td>Oceanic Society Whale Watch Cruises</td>
<td>Pillar Point Yacht Harbor</td>
<td>555-0488</td>
</tr>
<tr>
<td>Purisima Creek Redwoods Open Space Preserve</td>
<td>Higgins-Purisima Rd</td>
<td></td>
</tr>
</tbody>
</table>

9. Normally, the first row or column in a table is the heading information. Select the first row of the table by positioning the mouse pointer on the left border of the first cell in the first row until it changes to a right pointing arrow. Click the border and the first row of cells is highlighted.

10. On the Property inspector, for **Format**, select **Heading 5**.
11. Experiment with different text sizes for the rest of the table. Make sure all the text is readable.

12. Try changing the alignment of the text within each cell. Experiment by using the alignment buttons.

13. Experiment changing border and background colors by using the Bdr Color and Bg Color buttons on the lower part of the Property inspector. For example, you could use different colors to show related information in the table.

Although you can get carried away and embellish your text so much that it detracts from the content, visual organization is important for effective communication.

14. Use the following suggestions to enhance the presentation of the information:

- Select text and add hyperlink information to enable navigation to an organization’s web page. For the Half Moon Bay sample project you could add the following:
  - Police Department: http://www.half-moon-bay.ca.us/police-dept.html
  - Library: http://www.halfmoonbaylibrary.org
  - Half Moon Bay High School: http://www.coastside.net/hmbhs
  - Pilarcitos/Alternative High School: http://www.coastside.net/cusd/ae/ae.htm
If you have photographs for any of the organizations in the directory, you can insert a column in the table and add such images to the directory.

To preview the Directory page:
1. Save the Directory page.
2. Preview your work in a browser.
3. Close the browser window and then close the Directory Document window.

BUILDING THE EVENTS PAGE

The events page contains information about recurring events in the community. Many formats are possible for an events calendar. For example, it can be displayed in tabular form (as a table) similar to a wall calendar. For the events calendar on this page, you use a list that highlights only important months.

1. Create a new page in Dreamweaver MX. Choose File > New.

   The New Document dialog box opens. The Basic Page category is displayed and the HTML page type is selected. That’s what you want.

2. Click Create.

   A new Document window opens.

To save the Events page:

You should save your work on a page as you build it, but always save a page when you are ready to create another page.

1. Create a title for this page. On the Document toolbar, type a title such as Half Moon Bay Events in the Title text box.

2. Make any other changes to the page properties according to your design plan.

3. From the menu bar, choose File > Save.

4. Navigate to the root folder.

5. Type events.htm (Windows) or events.html (Macintosh) in the Filename text box.
6. Click **Save**.

**To add text from a text file:**

1. Use a word processor to copy the text from your events document or the prepared text file named `events.txt` in the `content` subfolder.

2. In Dreamweaver MX, paste the copied text into the Events page. If necessary, change line breaks to paragraph breaks.

3. Format the heading for this page, such as *Half Moon Bay Events*, as you have done on the other pages.

4. To make the list more readable, add bullets to the list items under each subheading, as shown in the following figure.

   ![Image of Half Moon Bay Events list](image)

   To add a bullet to a paragraph, position the insertion point in the paragraph and either click **Unordered List** on the Property inspector or choose **Text > List > Unordered List** from the menu bar.

5. You can change some of the default properties of unordered and ordered lists. For example, after you have created an unordered list, suppose you decide you want square bullets. To change from the
default round bullets to square bullets, click any line in the list and choose Text > List > Properties to open the List Properties dialog box. Change to the desired style of bullets.

![List Properties dialog box]

6. You can enhance the presentation of the information by adding hyperlinks that will give viewers additional information. For example, the following events are hyperlinked on the sample Events page:

- Pacific Coast Dream Machines: http://www.norcalaahs.org/pcdms.htm
- Tour des Fleurs: http://www.halfmoonbaychamber.org/visiting_hmb/tourdefleurs.html
- Pescadero Arts and Fun Festival: http://www.pescaderoartsandfunfestival.com
- Half Moon Bay Art and Pumpkin Festival: http://www.miramarevents.com/pumpkinfest/

7. Save the Events page.

8. Test the Events page in a browser.

9. Close the browser window and close the Events Document window.

BUILDING THE MAP PAGE
Maps and driving directions to the town are really helpful to first-time visitors. You can present this information in a variety ways. In this activity, you use an image rollover to create the information on this page.


   The New Document dialog box opens. The Basic Page category is displayed, and the HTML page type is selected. That’s what you want.

2. Click Create.

   A new Document window opens.
**To save the Map page:**

You should save your work on a page as you build it, but always save a page when you are ready to create another page.

1. To create a title for this page, type a title such as *Half Moon Bay Map and Driving Directions* in the **Title** text box.

2. Make any other changes to the page properties according to your design plan.

3. From the menu bar, choose **File > Save**.

4. Navigate to the root folder.

5. Type *map.htm* (Windows) or *map.html* (Macintosh) in the **Filename** text box.

6. Click **Save**.

**To create a rollover:**

A **rollover** is an image that changes when the pointer moves over it. A rollover consists of two images: the original, or primary, image (displayed when the page is first loaded), and the rollover image (displayed when the pointer moves over the primary image). Creating an image rollover is simple. First pick two images you want to use. For the sample Half Moon Bay map, you can use hmb-region-map.jpg and hmb-local-map.jpg.

1. Type a heading such as *Half Moon Bay Map and Driving Directions* at the top of the page.

2. In the **Common** category on the Insert bar, click **Rollover Image**.

   The Insert Rollover Image dialog box opens.

3. In the **Image Name** text box, type *Area Map*.

4. Use the **Browse** buttons beside the Original Image and Rollover Image text boxes to navigate to the **images** subfolder in the root folder. Select the original image, such as *hmb-region-map.jpg*. Select the rollover image, such as *hmb-local-map.jpg*.

5. Check the **Preload Rollover Image** box to have Dreamweaver MX preload the image in the browser’s cache memory.

6. In the Alternate Text box, type a short description of your images, such as *Maps of the region around Half Moon Bay and the city center*.

7. You can add a hyperlink if you like. For this sample project, you can leave the **When Clicked, Go to URL** text box blank.
The Insert Rollover Image dialog box should look like the following figure.

8. Click **OK**.

The rollover image is inserted on the page.

9. If you would like to add a border to the image, select the image and type a number in the **Border** text box on the Property inspector.

To test the rollover:

1. Save the Map page.
2. Choose **File > Preview in Browser** and then choose the browser you want to use to preview the page.

3. In the browser, move the pointer over the primary image.
   
   The display should switch to the rollover image.

4. Close the browser window.

**To add driving directions and other information:**

Use the text-editing techniques described in previous steps to add information to the page. Here are some suggestions:

- Insert a layer or table to place information in a specific area.
- Use an ordered list to indicate the directions to the town.
- Add hyperlinks to text.
- Add other town images.

For example, the directions to Half Moon Bay are as follows:

   From San Francisco: Drive south on I-280 to Highway 92, then west on 92 to Half Moon Bay. Alternate route: Drive south on Highway 1 to Half Moon Bay.
   
   From San Mateo: Drive west on Highway 92 to Half Moon Bay.
   
   From San Jose: Drive north on I-280 to Highway 92, then west on 92 to Half Moon Bay.
   
   From Santa Cruz: Drive north on Highway 1 to Half Moon Bay.
   
   From Palo Alto: Drive north on Highway 101 or I-280 to Highway 92, then west on 92 to Half Moon Bay.
Activity 6: Connecting the Web Pages

Approximate time to complete: 30–45 minutes

In this activity, you create a table on the home page to provide the navigation links between the pages of your website. Then you use that table as a template to copy to the other pages. Finally you modify each page to ensure that you have the appropriate links.

To create a navigation table:

1. Open the home page (index.htm) in Dreamweaver MX. Choose File > Open, navigate to the root folder, and double-click the filename index.htm.

2. Position the insertion point at the bottom of the page.

3. In the Common category on the Insert bar, click Insert Table.

4. Create a table with 1 row, 5 columns, a width of 97%, and no border.

5. Click inside the table and choose Modify > Table > Select Table from the menu bar.

The figure below shows the directions placed in a layer beside the image.
6. On the Property inspector, select **Center** from the **Align** pop-up menu to center the table at the bottom of the page.

7. Move the pointer to the left edge of the table. Click when the pointer changes into an arrow pointing to the right.

   The whole row of cells is selected.

8. On the Property inspector, click the **Align Center** button (in the upper right part of the Property inspector).

   Now anything you put in a cell will be centered in the cell.

---

**To insert a Macromedia Flash button:**

You can easily create an interactive Macromedia Flash button inside Dreamweaver MX. Flash buttons are interactive graphics that link to other web pages.

1. In the first cell of the navigation table, type *Home*.

   (You don’t need a button for the home page on the home page!)

2. Click in the second cell of the table.

3. In the **Media** category on the Insert bar, click **Flash Button** (the second button from the left) to open the Insert Flash Button dialog box.

4. In the Insert Flash Button dialog box, set the following options.

   - **Style:** Select the button style that goes best with your site. For the sample Half Moon Bay site, the style is *Standard*.
• **Button text:** Type the name of the second button, such as *History*.

• **Font:** Select a font that goes with the rest of your site. For the sample Half Moon Bay site, the font is **Verdana**.

• **Size:** Select a font size for the button, for example **13**.

• **Link:** Click the **Browse** button. Navigate to the root folder and select the page the button links to, such as *history.htm*.

• **Target:** Leave this box blank.

• **Bg Color:** Leave this box blank.

• **Save as:** Click **Browse**. Navigate to the root folder. In the **Filename** box, type a button name that clearly identifies this button, such as *history-button.swf*. Click **Save**. (A filename with the extension “.swf” is a Macromedia Flash file.)

5. Click **OK** to close the Insert Flash Button dialog box.

You have now linked the History page to the home page.

6. Repeat steps 2 through 5 to create the remaining buttons (Directory, Events, and Map) in the navigation table.
You have linked each of the other four pages to the home page. The Home item is included in the navigation table to identify the current page. It would be confusing to have a button on a page that links to that page.

7. Save the document.


The results should be similar to those in the following figure.

![Half Moon Bay Home Page](image)

9. Close the browser window.

**To copy the navigation table:**

To create a similar table for the other pages of the website, you can use the copy-and-paste feature.

1. To select the entire navigation table, click in the table and choose Modify > Table > Select Table. Choose Edit > Copy or use the keyboard shortcut command.

2. Choose File > Open. Navigate to the History page and open it.
3. Position the insertion point at the end of the History page and press Shift+Enter (Windows) or Shift+Return (Macintosh).

4. Choose Edit > Paste, or use the keyboard shortcut command.

   The table is copied into the History page.

**To modify the navigation table:**

The entire table, including the hyperlinks, has been copied. Now you need to modify the table to include a link back to the home page and to remove the link to the History page itself.

1. In the navigation table, select the word “Home” and delete it.

2. In the Media category on the Insert bar, click Flash Button (the second button from the left) to open the Insert Flash Button dialog box.

3. In the Insert Flash Button dialog box, set the following options.

   - **Style:** Select the same button style as before. For the sample Half Moon Bay site, the style is Standard.
   - **Button text:** Type the name of the first button, such as Home.
   - **Font:** Select the same font as before. For the sample Half Moon Bay site, the font is Verdana.
   - **Size:** Select the same font size as before, for example 13.
   - **Link:** Click the Browse button. Navigate to the root folder and select the page the button links to, such as index.htm.
   - **Target:** Leave this box blank.
   - **Bg Color:** Leave this box blank.
   - **Save as:** Click Browse. Navigate to the root folder. In the Filename box, type a button name that clearly identifies this button, such as home-button.swf. Click Save.

4. Click OK to close the Insert Flash Button dialog box.

   You have now created a link back to the home page.

5. In the navigation table, select the History button and delete it.

6. Type the word History in the cell. Change the formatting of “History” to match the way you formatted “Home.”
The History page with its navigation bar should look like the figure below.

7. Save your document.

8. Preview the History page in a browser. Click the Preview/Debug in Browser button and select a browser.

9. Open each of the three remaining pages and do a similar process:

   - Paste in the navigation table.
   - Delete the button for the current page and replace it with a formatted text label for the page.
   - Replace the text label that’s not for the current page (such as the “Home” label) with a Flash button you’ve already created:
     - On the Media tab of the Insert bar, click the Flash button (the first button on the left).
     - Browse to the root folder for your site and select a Flash button, such as home-button.swf.
   - Save your work and preview the page in a browser.
Activity 7: Testing the Website

Approximate time to complete: 15–20 minutes

When you develop a website on your computer (instead of on a web server) you can test it thoroughly before posting it to a server. In this activity, you learn how to do a technical test to assure that it’s ready to go.

To conduct a technical test of the website:

1. Start a web browser.

2. From the menu bar, choose File > Open. Navigate to the root folder, and double-click the filename (or icon) index.htm.

   Your site opens in the browser.

3. Test all the internal links—the links between the pages of your site.
   - Starting with the home page, click each of the links in the navigation table at the bottom of the page to verify that the proper page appears. Make notes of any links that do not perform properly. (Errors such as links that don’t function properly are called bugs.)
   - Test the links in the navigation table on each of the other pages in your site.

4. Test all the external links—the links to other websites. On each page of your site, click each link to an external site to verify that the proper website appears. Make notes of any links that do not perform properly.

   To return to your site from another site, click the Back button in the browser window.

   Note: Be considerate to others. Do not fully test email links on the pages of your site by actually sending an e-mail message.

5. Close the browser when you have completed your testing.

6. If you discovered any bugs during your technical test, open your site in Dreamweaver MX, fix the bugs, and save your work.

7. Repeat steps 1–6 until your website is free of bugs.
Activity 8: Managing the Website

Approximate time to complete: 30–45 minutes

In this activity, you learn how to view the site structure and post your website to a server.

To view the site structure:

Dreamweaver MX helps you organize the files of your site by maintaining parallel file and folder structures at the local and remote sites.

1. Start Dreamweaver MX.

2. If necessary, choose Window > Site to display the Site panel (Windows) or the Site window (Macintosh).

The structure of the website should be similar to the structure shown here when it is completed.

To set up the remote site and post to a server:

After you have checked all the links and saved all your work, you are ready to post your site to a server.

1. On the Site panel, click Connects to Remote Host (the button with a black dot and two computer connectors).

The Site Definition for half-moon-bay_site dialog box opens.
2. In the Category list, select Remote Info.

3. Click the arrow beside the Access box and select FTP.

4. Check with the systems administrator for the school to get the information you need to define the website: the FTP host, host directory, and so on.

   When you are ready to post the web pages to the World Wide Web, be sure to contact the system administrator and technology coordinator for your school.